RFR: 8300140: ZipFile.isSignatureRelated returns true for files in META-INF subdirectories [v15]

Eirik Bjorsnos duke at openjdk.org
Fri Jan 27 22:45:17 UTC 2023

On Fri, 27 Jan 2023 22:16:18 GMT, Weijun Wang <weijun at openjdk.org> wrote:

> Maybe we can rename `ZipFile::isSignatureRelated` to `ZipFile::isBlockOrSF` as well?

The term "signature related" seems to be used quite extensively around ZipFile and also in JavaUtilZipFileAccess. Semantics are very similar, but not exactly equal. Because of this, I'm a bit reluctant to rename it.

> I'll approved this PR. Thanks.

Thank for your help and guidance in reviewing this PR!


PR: https://git.openjdk.org/jdk/pull/11976

More information about the security-dev mailing list