RFR: 8318096: Add getParams method in PublicKey and PrivateKey [v2]

David M. Lloyd duke at openjdk.org
Wed Oct 18 18:35:41 UTC 2023

On Wed, 18 Oct 2023 18:23:31 GMT, Weijun Wang <weijun at openjdk.org> wrote:

> > Would `getParameterSpec` be a better/more descriptive name, given that the thing it returns is an `AlgorithmParameterSpec`?
> > 
> > (Disclosure: Our security library (WildFly Elytron) has a `getParameterSpec` on every one of its key implementation classes... it would be serendipitous if it would retroactively fit in with this change!)
> We already have the `getParams` method everywhere and we are actually reusing that name and make all these methods a mesh (not a mess). If we create another method, there will be 2 ways to do the same thing and users will be confused. And we cannot simply deprecate the old one since that will be even more disruptive.

Okay, I didn't know about the old name, that makes sense.


PR Comment: https://git.openjdk.org/jdk/pull/16222#issuecomment-1769107414

More information about the security-dev mailing list