RFR: 8327818: Implement Kerberos debug with sun.security.util.Debug [v7]
Sean Coffey
coffeys at openjdk.org
Fri Mar 15 13:46:12 UTC 2024
On Fri, 15 Mar 2024 13:35:29 GMT, Weijun Wang <weijun at openjdk.org> wrote:
>> src/java.base/share/classes/sun/security/util/Debug.java line 180:
>>
>>> 178: * @return a new Debug object if the property is true
>>> 179: */
>>> 180: public static Debug of(String option, String property) {
>>
>> the `property` name is a bit confusing here IMO. Most use cases will be string corresponding to a boolean (or null) - Would a boolean paramater make more sense ? Otherwise. I'd suggest renaming variable to something like `debugEnabled`
>
> I was thinking that it will contain more options like `true+timestamp` later. By that time, we only need to update the `Debug` class to add this feature.
I see. Seems reasonable then.
I can see how folding these krb5 debug options in under the `java.security.debug` property will make debugging easier for everyone. Hopefully, something that can be done in the near future in a follow on patch.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/18199#discussion_r1526308374
More information about the security-dev
mailing list