RFR: 8331008: Implement JEP 478: Key Derivation Function API (Preview) [v28]

Sean Mullan mullan at openjdk.org
Mon May 13 19:40:22 UTC 2024


On Mon, 13 May 2024 09:12:20 GMT, Alan Bateman <alanb at openjdk.org> wrote:

>> Kevin Driver has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   re-enable preview annotations
>
> src/java.base/share/classes/javax/crypto/spec/HKDFParameterSpec.java line 206:
> 
>> 204:      * @return a {@code Builder} to mutate
>> 205:      */
>> 206:     static Builder extract() {
> 
> The expand method return an Expand object, the extractExpand returns a ExtractExpand. It looks a bit strange to have the extract method return a Builder rather than extract something or return an Extract object. Try renaming it to builder and see if it looks any better.

I agree with Alan the name is a little confusing because it doesn't directly return an `Extract` object. Suggest renaming to `builder()` as Alan suggests.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/18924#discussion_r1598977185



More information about the security-dev mailing list