RFR: 8346129: Simplify EdDSA & XDH curve name usage [v3]
Sean Mullan
mullan at openjdk.org
Wed Feb 26 21:10:55 UTC 2025
On Tue, 25 Feb 2025 20:24:16 GMT, Anthony Scarpino <ascarpino at openjdk.org> wrote:
>> Hi,
>>
>> I need a review for the following change. Naming conventions for EdDSA and XDH have inconsistencies between DisabledAlgorithms and KeyPairGenerator. These internal changes help make it more consistent when parsing the actual curve being used vs the broader algorithm name.
>>
>> thanks
>>
>> Tony
>
> Anthony Scarpino has updated the pull request incrementally with one additional commit since the last revision:
>
> Undo AbtractAlgorithConstraint change & use AsymmetricKey
src/java.base/share/classes/sun/security/util/DisabledAlgorithmConstraints.java line 267:
> 265: }
> 266:
> 267: private static List<String> getNamedCurveFromKey(Key key) {
This method should probably be renamed to `getNamedParametersFromKey`, and the comment in `permits` (line 255) should be changed to // Check if named parameters or curves in the key are disabled.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/23647#discussion_r1972395717
More information about the security-dev
mailing list