RFR: 8349583: Add mechanism to disable signature schemes based on their TLS scope [v18]

Artur Barashev abarashev at openjdk.org
Wed Mar 19 19:38:09 UTC 2025


On Tue, 18 Mar 2025 23:15:29 GMT, Anthony Scarpino <ascarpino at openjdk.org> wrote:

>> Artur Barashev has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   Typo fix
>
> test/jdk/sun/security/ssl/SignatureScheme/AbstractCheckSignatureSchemes.java line 135:
> 
>> 133:         int type = Byte.toUnsignedInt(tlsRecord.get());
>> 134:         int ver_major = Byte.toUnsignedInt(tlsRecord.get());
>> 135:         int ver_minor = Byte.toUnsignedInt(tlsRecord.get());
> 
> These 3 variables appear to not be used.

Yes, that code was copied from the original `SigSchemePropOrdering` file and that's the pattern seen throughout our SSL code when reading TLS record. I think it's done for clarity. Alternatively we can remove assignments to unused variables and add a comment for every read operation.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/23681#discussion_r2004149338


More information about the security-dev mailing list