RFR: 8346129: Simplify EdDSA & XDH curve name usage [v6]

Artur Barashev abarashev at openjdk.org
Tue Mar 25 16:32:24 UTC 2025


On Fri, 21 Mar 2025 20:36:47 GMT, Anthony Scarpino <ascarpino at openjdk.org> wrote:

>> Hi,
>> 
>> I need a review for the following change. Naming conventions for EdDSA and XDH have inconsistencies between DisabledAlgorithms and KeyPairGenerator. These internal changes help make it more consistent when parsing the actual curve being used vs the broader algorithm name.
>> 
>> thanks
>> 
>> Tony
>
> Anthony Scarpino has updated the pull request incrementally with one additional commit since the last revision:
> 
>   comments on test

test/jdk/sun/security/util/AlgorithmConstraints/DisabledAlgorithmPermits.java line 143:

> 141:                 throw new AssertionError("failed.  Expected " +
> 142:                     tc.expected);
> 143:             }

I suggest replacing this check with `assertEquals`.

test/jdk/sun/security/util/AlgorithmConstraints/DisabledAlgorithmPermits.java line 165:

> 163:                 throw new AssertionError("failed.  Expected " +
> 164:                     tc.expected);
> 165:             }

Same as above.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/23647#discussion_r2012489410
PR Review Comment: https://git.openjdk.org/jdk/pull/23647#discussion_r2012489790


More information about the security-dev mailing list