RFR: 8301995: Move invokedynamic resolution information out of ConstantPoolCacheEntry [v6]

Richard Reingruber rrich at openjdk.org
Thu Mar 16 09:10:39 UTC 2023


On Wed, 15 Mar 2023 19:04:41 GMT, Martin Doerr <mdoerr at openjdk.org> wrote:

>> Matias Saavedra Silva has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   Fixed aarch64 interpreter mistake
>
> src/hotspot/cpu/ppc/templateTable_ppc_64.cpp line 3398:
> 
>> 3396:   const Bytecodes::Code code = bytecode();
>> 3397:   const bool is_invokeinterface  = code == Bytecodes::_invokeinterface;
>> 3398:   const bool is_invokedynamic    = code == false; // should not reach here with invokedynamic
> 
> This looks strange! I guess you wanted to delete more?

Basically I kept the local variable as a name for the (now) constant value passed in the call at L3409.

The parameter cannot be eliminated since `load_invoke_cp_cache_entry()` is declared in a shared header.

I could replace the variable reference in the call with `false /* is_invokedynamic */` if you like that better. Personally I'd prefer the current version.

-------------

PR: https://git.openjdk.org/jdk/pull/12778


More information about the serviceability-dev mailing list