RFR: 8301995: Move invokedynamic resolution information out of ConstantPoolCacheEntry [v6]
Martin Doerr
mdoerr at openjdk.org
Thu Mar 16 09:29:26 UTC 2023
On Thu, 16 Mar 2023 09:07:27 GMT, Richard Reingruber <rrich at openjdk.org> wrote:
>> src/hotspot/cpu/ppc/templateTable_ppc_64.cpp line 3398:
>>
>>> 3396: const Bytecodes::Code code = bytecode();
>>> 3397: const bool is_invokeinterface = code == Bytecodes::_invokeinterface;
>>> 3398: const bool is_invokedynamic = code == false; // should not reach here with invokedynamic
>>
>> This looks strange! I guess you wanted to delete more?
>
> Basically I kept the local variable as a name for the (now) constant value passed in the call at L3409.
>
> The parameter cannot be eliminated since `load_invoke_cp_cache_entry()` is declared in a shared header.
>
> I could replace the variable reference in the call with `false /* is_invokedynamic */` if you like that better. Personally I'd prefer the current version.
I meant `code == false`. That was probably not intended.
-------------
PR: https://git.openjdk.org/jdk/pull/12778
More information about the serviceability-dev
mailing list