RFR: JDK-8316691: Heap dump: separate stack traces for mounted virtual threads [v2]

Alex Menkov amenkov at openjdk.org
Wed Sep 27 22:44:48 UTC 2023


On Wed, 27 Sep 2023 07:11:26 GMT, David Holmes <dholmes at openjdk.org> wrote:

>> Alex Menkov has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   David's feedback
>
> test/hotspot/jtreg/serviceability/jvmti/vthread/HeapDump/VtreadInHeapDump.java line 1:
> 
>> 1: /*
> 
> The file/class name is wrong Vtread instead of VThread

Fixed.

> test/lib/jdk/test/lib/hprof/model/Root.java line 145:
> 
>> 143: 
>> 144:     public long getReferrerId() {
>> 145:         return refererId;
> 
> Spelling: `referrerId`

This is existing field in the class.
There are a number (45) of misspelled "referer" in the lib, including some public methods (like getReferer() in line 140).
If you think it makes sense to fix the, I can file a separate CR for this.

> test/lib/jdk/test/lib/hprof/model/ThreadObject.java line 9:
> 
>> 7:  * published by the Free Software Foundation.  Oracle designates this
>> 8:  * particular file as subject to the "Classpath" exception as provided
>> 9:  * by Oracle in the LICENSE file that accompanied this code.
> 
> Test files do not use the CPE.

Fixed.

> test/lib/jdk/test/lib/hprof/model/ThreadObject.java line 33:
> 
>> 31: 
>> 32:     private final long id;            // ID of the JavaThing we refer to
>> 33: //    private JavaHeapObject referer = null;
> 
> Remove this?

Done.

> test/lib/jdk/test/lib/hprof/parser/HprofReader.java line 917:
> 
>> 915:         System.out.println("WARNING: " + msg);
>> 916:     }
>> 917: /*
> 
> Should this be deleted?

Yes. Done.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/15869#discussion_r1339290812
PR Review Comment: https://git.openjdk.org/jdk/pull/15869#discussion_r1339261751
PR Review Comment: https://git.openjdk.org/jdk/pull/15869#discussion_r1339291528
PR Review Comment: https://git.openjdk.org/jdk/pull/15869#discussion_r1339291698
PR Review Comment: https://git.openjdk.org/jdk/pull/15869#discussion_r1339291988


More information about the serviceability-dev mailing list