RFR: 8247972: incorrect implementation of JVM TI GetObjectMonitorUsage [v3]
Serguei Spitsyn
sspitsyn at openjdk.org
Thu Feb 8 09:58:56 UTC 2024
On Wed, 7 Feb 2024 22:43:36 GMT, Daniel D. Daugherty <dcubed at openjdk.org> wrote:
>> Serguei Spitsyn has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains three additional commits since the last revision:
>>
>> - Merge
>> - review: thread in notify waiter list can't be BLOCKED
>> - 8324677: Specification clarification needed for JVM TI GetObjectMonitorUsage
>
> test/hotspot/jtreg/vmTestbase/nsk/jvmti/GetObjectMonitorUsage/objmonusage001/objmonusage001.cpp line 161:
>
>> 159:
>> 160: if (inf.notify_waiter_count != notifyWaiterCount) {
>> 161: printf("(%d) waiter_count expected: %d, actually: %d\n",
>
> nit typo: s/waiter_count/notify_waiter_count/
Nice catch, thanks!
> test/hotspot/jtreg/vmTestbase/nsk/jvmti/GetObjectMonitorUsage/objmonusage003/objmonusage003.cpp line 150:
>
>> 148:
>> 149: if (inf.notify_waiter_count != notifyWaiterCount) {
>> 150: printf("(%d) waiter_count expected: %d, actually: %d\n",
>
> nit typo: s/waiter_count/notify_waiter_count/
Nice catch, thanks!
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/17680#discussion_r1482702600
PR Review Comment: https://git.openjdk.org/jdk/pull/17680#discussion_r1482702844
More information about the serviceability-dev
mailing list