RFR: 8324799: Use correct extension for C++ test headers

Coleen Phillimore coleenp at openjdk.org
Wed Feb 28 14:29:55 UTC 2024


On Wed, 28 Feb 2024 14:13:58 GMT, Coleen Phillimore <coleenp at openjdk.org> wrote:

>> Please review this change that renames some test .h files to .hpp.  These
>> files contain C++ code and should be named accordingly.  Some of them contain
>> uses of NULL, which we change to nullptr.
>> 
>> The renamed files are:
>> 
>> test/hotspot/jtreg/vmTestbase/nsk/share/aod/aod.h
>> test/hotspot/jtreg/vmTestbase/nsk/share/jni/jni_tools.h  
>> test/hotspot/jtreg/vmTestbase/nsk/share/jvmti/jvmti_tools.h
>> test/hotspot/jtreg/vmTestbase/nsk/share/jvmti/JVMTITools.h
>> test/hotspot/jtreg/vmTestbase/nsk/share/native/nsk_tools.h 
>> 
>> test/lib/jdk/test/lib/jvmti/jvmti_thread.h
>> test/lib/jdk/test/lib/jvmti/jvmti_common.h
>> test/lib/native/testlib_threads.h 
>> 
>> The #include updates were performed mostly mechanically, and builds would fail
>> if there were mistakes.  The exception is test
>> test/hotspot/jtreg/serviceability/jvmti/FollowReferences/FieldIndices/libFieldIndicesTest.cpp,
>> which was added after I'd done the mechanical update, so was updated by hand.
>> 
>> The copyright updates were similarly performed mechanically. All but a handful
>> of the including files have already had their copyrights updated recently,
>> likely as part of JDK-8324681.
>> 
>> Thus, the only "interesting" changes are to the renamed files.
>> 
>> Testing: mach5 tier1
>
> test/hotspot/jtreg/serviceability/jvmti/vthread/FollowReferences/libVThreadStackRefTest.cpp line 26:
> 
>> 24: #include <jni.h>
>> 25: #include <jvmti.h>
>> 26: #include <jvmti_common.hpp>
> 
> Should this be in quotes rather than <> ?

Suggestion:

#include "jvmti_common.hpp"

> test/hotspot/jtreg/serviceability/jvmti/vthread/GetThreadStateMountedTest/libGetThreadStateMountedTest.cpp line 26:
> 
>> 24: #include <jni.h>
>> 25: #include <jvmti.h>
>> 26: #include <jvmti_common.hpp>
> 
> Another.

Suggestion:

#include "jvmti_common.hpp"

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/18035#discussion_r1506033122
PR Review Comment: https://git.openjdk.org/jdk/pull/18035#discussion_r1506033741


More information about the serviceability-dev mailing list