RFR: 8261125: Move VM_Operation to vmOperation.hpp
Ioi Lam
iklam at openjdk.java.net
Thu Feb 4 06:16:00 UTC 2021
vmOperations.hpp declares the VM_Operation class, as well as a hodge podge of subclasses such as VM_ForceSafepoint, VM_DeoptimizeFrame.
Out of the 1000 hotspot .o files, about 680 include vmOperations.hpp (mostly transitively). In most cases, they just need to use the VM_Operation class.
So we should move VM_Operation to its own header: vmOperation.hpp (no "s").
After the refactoring, vmOperations.hpp is included only 64 times. The inclusion count of threadSMR.hpp is also reduced from 687 to 99. HotSpot build time is improved by about 0.4%.
Tested with mach5: tier1, builds-tier2, builds-tier3, builds-tier4 and builds-tier5. Also locally: aarch64, arm, ppc64, s390, x86, and zero.
-------------
Commit messages:
- 8261125: Move VM_Operation to vmOperation.hpp
Changes: https://git.openjdk.java.net/jdk/pull/2398/files
Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=2398&range=00
Issue: https://bugs.openjdk.java.net/browse/JDK-8261125
Stats: 347 lines in 24 files changed: 189 ins; 142 del; 16 mod
Patch: https://git.openjdk.java.net/jdk/pull/2398.diff
Fetch: git fetch https://git.openjdk.java.net/jdk pull/2398/head:pull/2398
PR: https://git.openjdk.java.net/jdk/pull/2398
More information about the shenandoah-dev
mailing list