RFR: 8261125: Move VM_Operation to vmOperation.hpp
Coleen Phillimore
coleenp at openjdk.java.net
Thu Feb 4 13:25:41 UTC 2021
On Thu, 4 Feb 2021 05:38:49 GMT, Ioi Lam <iklam at openjdk.org> wrote:
> vmOperations.hpp declares the VM_Operation class, as well as a hodge podge of subclasses such as VM_ForceSafepoint, VM_DeoptimizeFrame.
>
> Out of the 1000 hotspot .o files, about 680 include vmOperations.hpp (mostly transitively). In most cases, they just need to use the VM_Operation class.
>
> So we should move VM_Operation to its own header: vmOperation.hpp (no "s").
>
> After the refactoring, vmOperations.hpp is included only 64 times. The inclusion count of threadSMR.hpp is also reduced from 687 to 99. HotSpot build time is improved by about 0.4%.
>
> Tested with mach5: tier1, builds-tier2, builds-tier3, builds-tier4 and builds-tier5. Also locally: aarch64, arm, ppc64, s390, x86, and zero.
Ok!
-------------
Marked as reviewed by coleenp (Reviewer).
PR: https://git.openjdk.java.net/jdk/pull/2398
More information about the shenandoah-dev
mailing list