RFR: 8317809: Insertion of free code blobs into code cache can be very slow during class unloading [v3]

Thomas Schatzl tschatzl at openjdk.org
Thu Nov 30 10:37:11 UTC 2023


On Mon, 27 Nov 2023 14:53:34 GMT, Albert Mingkun Yang <ayang at openjdk.org> wrote:

>> Thomas Schatzl has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains five commits:
>> 
>>  - Merge branch 'master' into mergeme
>>  - iwalulya review, naming
>>  - 8317809 Insert code blobs in a sorted fashion to exploit the finger-optimization when adding, making this procedure O(n) instead of O(n^2)
>>    
>>    Introduce a globally available ClassUnloadingContext that contains common methods pertaining to class and code unloading.
>>    GCs may use it to efficiently manage unlinked class loader datas and nmethods to allow use of common methods (unlink/merge).
>>    
>>    The steps typically are registering a new to be unlinked CLD/nmethod, and then purge its memory later. STW collectors perform
>>    this work in one big chunk taking the CodeCache_lock, for the entire duration, while concurrent collectors lock/unlock for every
>>    insertion to allow for concurrent users for the lock to progress.
>>    
>>    Some care has been taken to stay consistent with an "unloading = unlinking + purge" scheme; however particularly the existing
>>    CLD handling API (still) mixes unlinking and purging in its CLD::unload() call. To simplify this change that is mostly geared
>>    towards separating nmethod unlinking from purging, to make code blob freeing O(n) instead of O(n^2).
>>    
>>    Upcoming changes will
>>    * separate nmethod unregistering from nmethod purging to allow doing that in bulk (for the STW collectors); that can significantly
>>      reduce code purging time for the STW collectors.
>>    * better name the second stage of unlinking (called "cleaning" throughout, e.g. the work done in `G1CollectedHeap::complete_cleaning`)
>>    * untangle CLD unlinking and what's called "cleaning" now to allow moving more stuff into the second unlinking stage for better
>>      parallelism
>>    * G1: move some signifcant tasks from the remark pause to concurrent (unregistering nmethods, freeing code blobs and cld/metaspace purging)
>>    * Maybe move Serial/Parallel GC metaspace purging closer to other unlinking/purging code to keep things local and allow easier logging.
>>  - Only run test case on debug VMs, sufficient
>>  - 8320331 g1 full gc "during" verification accesses half-unloaded metadata
>
> src/hotspot/share/gc/shared/classUnloadingContext.hpp line 63:
> 
>> 61: };
>> 62: 
>> 63: class DefaultClassUnloadingContext : public ClassUnloadingContext {
> 
> I don't understand why they need to be two classes, even after reading "These are the reason for the class hierarchy for...". The reference to future/other PR(s) in the description doesn't really help -- it's unclear what is *necessary* for the current PR and what is preparation for future PR(s).

The base class is unnecessary for this change, but very nice to have for future changes. I'll just merge them for now, and separate them again later.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/16759#discussion_r1410476983


More information about the shenandoah-dev mailing list