RFR: 8317809: Insertion of free code blobs into code cache can be very slow during class unloading [v4]
Thomas Schatzl
tschatzl at openjdk.org
Thu Nov 30 11:38:28 UTC 2023
> Insert code blobs in a sorted fashion to exploit the finger-optimization when adding, making this procedure O(n) instead of O(n^2)
>
> Introduces a globally available ClassUnloadingContext that contains common methods pertaining to class and code unloading. GCs may use it to efficiently manage unlinked class loader datas and nmethods to allow use of common methods (unlink/merge).
>
> The steps typically are registering a new to be unlinked CLD/nmethod, and then purge its memory later. STW collectors perform this work in one big chunk taking the CodeCache_lock, for the entire duration, while concurrent collectors lock/unlock for every insertion to allow for concurrent users for the lock to progress.
>
> Some care has been taken to stay consistent with an "unloading = unlinking + purge" scheme; however particularly the existing CLD handling API (still) mixes unlinking and purging in its CLD::unload() call. To simplify this change that is mostly geared towards separating nmethod unlinking from purging, to make code blob freeing O(n) instead of O(n^2).
>
> Upcoming changes will
> * separate nmethod unregistering from nmethod purging to allow doing that in bulk (for the STW collectors); that can significantly reduce code purging time for the STW collectors.
> * better name the second stage of unlinking (called "cleaning" throughout, e.g. the work done in `G1CollectedHeap::complete_cleaning`)
> * untangle CLD unlinking and what's called "cleaning" now to allow moving more stuff into the second unlinking stage for better parallelism
> * G1: move some significant tasks from the remark pause to concurrent (unregistering nmethods, freeing code blobs and cld/metaspace purging)
> * Maybe move Serial/Parallel GC metaspace purging closer to other unlinking/purging code to keep things local and allow easier logging.
>
> These are the reason for the class hierarchy for `ClassUnloadingContext`: the goal is to ultimately have about this phasing (for G1):
> 1. collect all dead CLDs, using the `register_unloading_class_loader_data` method *only*
> 2. parallelize the stuff in `ClassLoaderData::unload()` in one way or another, adding them to the `complete_cleaning` (parallel) phase.
> 3. `purge_nmethods`, `free_code_blobs` and the `remove_unlinked_nmethods_from_code_root_set` (from JDK-8317007) will be concurrent.
>
> Particularly the split of `SystemDictionary::do_unloading` into "only" traversing the CLDs to find the dead ones and then in parallel process them in 2. above warrants a separate `ClassUnloadingCo...
Thomas Schatzl has updated the pull request incrementally with three additional commits since the last revision:
- remove trailing whitespace
- fix indentation after recent commit
- Address ayang/iwalulya review comments, remove inheritance in ClassUnloadingContext for now as unnecessary for this change, use iterators, other review comments
-------------
Changes:
- all: https://git.openjdk.org/jdk/pull/16759/files
- new: https://git.openjdk.org/jdk/pull/16759/files/e8c8477a..801426a2
Webrevs:
- full: https://webrevs.openjdk.org/?repo=jdk&pr=16759&range=03
- incr: https://webrevs.openjdk.org/?repo=jdk&pr=16759&range=02-03
Stats: 103 lines in 9 files changed: 19 ins; 40 del; 44 mod
Patch: https://git.openjdk.org/jdk/pull/16759.diff
Fetch: git fetch https://git.openjdk.org/jdk.git pull/16759/head:pull/16759
PR: https://git.openjdk.org/jdk/pull/16759
More information about the shenandoah-dev
mailing list