RFR: 8330076: [NMT] add/make a mandatory MEMFLAGS argument to family of os::reserve/commit/uncommit memory API [v10]
Stefan Karlsson
stefank at openjdk.org
Fri Apr 19 08:51:00 UTC 2024
On Fri, 19 Apr 2024 08:27:09 GMT, Afshin Zafari <azafari at openjdk.org> wrote:
>> src/hotspot/os/windows/os_windows.cpp line 3401:
>>
>>> 3399: // Reserve memory at an arbitrary address, only if that area is
>>> 3400: // available (and not reserved for something else).
>>> 3401: char* os::pd_attempt_reserve_memory_at(char* addr, size_t bytes, bool exec, MEMFLAGS nmt_flag) {
>>
>> Most of the time the MEMFLAGS parameters are called flag but in some places they are called nmt_flag. Could they always be called flag? This might require some minor renames in some files, but I think that would be OK.
>
> `reserve_large_pages_individually` has a local `flags` variable and
> `allocate_pages_individually` has a `flags` param in their definitions. So, the `nmt_flag` is used to avoid confusing different flags while reading the code.
> Other cases where there would be no ambiguity, the `nmt_flag` is renamed to `flag`.
Could you instead rename the local 'flags' variable instead?
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/18745#discussion_r1572047252
More information about the shenandoah-dev
mailing list