RFR: 8345656: Move os alignment functions out of ReservedSpace [v2]

Stefan Karlsson stefank at openjdk.org
Mon Dec 9 13:11:40 UTC 2024


On Mon, 9 Dec 2024 02:36:08 GMT, David Holmes <dholmes at openjdk.org> wrote:

> I don't see the removal of the "moved" functions from ./share/memory/virtualspace.cpp ??

Good point. That got lost in the split-out from my other rewrites.

> src/hotspot/share/runtime/os.hpp line 408:
> 
>> 406:   static size_t vm_page_size() { return OSInfo::vm_page_size(); }
>> 407: 
>> 408:   static size_t align_up_vm_page_size(size_t size)   { return align_up  (size, os::vm_page_size()); }
> 
> Style Nit: please don't add extra whitespace before the opening function parenthesis.

I find that it makes the code easier to read and the rest of the code uses various extra whitespace to make the code clearer. Is this a strong request?

-------------

PR Comment: https://git.openjdk.org/jdk/pull/22600#issuecomment-2527880191
PR Review Comment: https://git.openjdk.org/jdk/pull/22600#discussion_r1875955997


More information about the shenandoah-dev mailing list