RFR: 8345656: Move os alignment functions out of ReservedSpace [v2]
David Holmes
dholmes at openjdk.org
Tue Dec 10 07:31:45 UTC 2024
On Mon, 9 Dec 2024 13:08:46 GMT, Stefan Karlsson <stefank at openjdk.org> wrote:
>> src/hotspot/share/runtime/os.hpp line 408:
>>
>>> 406: static size_t vm_page_size() { return OSInfo::vm_page_size(); }
>>> 407:
>>> 408: static size_t align_up_vm_page_size(size_t size) { return align_up (size, os::vm_page_size()); }
>>
>> Style Nit: please don't add extra whitespace before the opening function parenthesis.
>
> I find that it makes the code easier to read and the rest of the code uses various extra whitespace to make the code clearer. Is this a strong request?
No not a strong request. I see there is precedent for this already in the file - though in some cases it isn't even needed for alignment purposes. I find extra whitespace between a function name and the opening parenthesis to be visually jarring and it makes me have to re-read to ensure I'm not mis-reading something. YMMV.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/22600#discussion_r1877485988
More information about the shenandoah-dev
mailing list