RFR: 8333750: GenShen: Only instantiate young/old generations in generational mode [v3]

William Kemper wkemper at openjdk.org
Tue Jun 11 18:35:39 UTC 2024


On Tue, 11 Jun 2024 02:45:21 GMT, Y. Srinivas Ramakrishna <ysr at openjdk.org> wrote:

>> William Kemper has updated the pull request incrementally with three additional commits since the last revision:
>> 
>>  - Make age and youth const
>>  - Do not age regions after completing old mark
>>  - Detect cancellation of old GC after final mark.
>
> src/hotspot/share/gc/shenandoah/shenandoahHeap.cpp line 2408:
> 
>> 2406: }
>> 2407: 
>> 2408: void ShenandoahHeap::final_update_refs_do_regions() {
> 
> The name of this method is too generic, and doesn't tell you if and what you are doing? Is there a better possible name?
> 
> I see that it's a virtual method and in one case does pinning recalibration and in the other additionally region age updates. Is there a good name for these two? 
> 
> May be `final_update_refs_update_region_states()` analogous to the name of the timing phase, like for the `trash_cset` case below?

Yes, I thought the original name was too generic. `update_heap_region_states` doesn't indicate which phase of the collection it pertains to. I'll go with `final_update_refs_update_region_states` to match the timing phase.

-------------

PR Review Comment: https://git.openjdk.org/shenandoah/pull/444#discussion_r1635322211


More information about the shenandoah-dev mailing list