RFR: 1199: Enforce maintainer approval in JBS before allowing to integrate backports into updates projects [v6]

Guoxiong Li gli at openjdk.org
Thu Sep 22 11:27:49 UTC 2022

On Wed, 21 Sep 2022 10:20:27 GMT, Magnus Ihse Bursie <ihse at openjdk.org> wrote:

>> Guoxiong Li has updated the pull request incrementally with one additional commit since the last revision:
>>   Fix tests.
> bots/pr/src/main/java/org/openjdk/skara/bots/pr/ApprovalCommand.java line 39:
>> 37:     private static void showHelp(PrintWriter writer) {
>> 38:         writer.println("""
>> 39:                 usage: `/approval [yes|no|y|n]`
> Perhaps a minor issue, but I think the command should be `/approve` instead of `/approval`. We have verbs in the other commands, such as `/sponsor` and `/integrate`.

I agree the command name `approve` is better. Do the related class names and method names need to be adjusted? Or only need to revise the command name and its help info?

            Map.entry("approval", new ApprovalCommand())  --> change to `approve`


PR: https://git.openjdk.org/skara/pull/1364

More information about the skara-dev mailing list