RFR: 1199: Enforce maintainer approval in JBS before allowing to integrate backports into updates projects [v6]

Guoxiong Li gli at openjdk.org
Thu Sep 22 13:42:55 UTC 2022

On Thu, 22 Sep 2022 11:25:05 GMT, Guoxiong Li <gli at openjdk.org> wrote:

>> bots/pr/src/main/java/org/openjdk/skara/bots/pr/ApprovalCommand.java line 39:
>>> 37:     private static void showHelp(PrintWriter writer) {
>>> 38:         writer.println("""
>>> 39:                 usage: `/approval [yes|no|y|n]`
>> Perhaps a minor issue, but I think the command should be `/approve` instead of `/approval`. We have verbs in the other commands, such as `/sponsor` and `/integrate`.
> I agree the command name `approve` is better. Do the related class names and method names need to be adjusted? Or only need to revise the command name and its help info?
>             Map.entry("approval", new ApprovalCommand())  --> change to `approve`

I changed the command name `approval` to `approve` just now.


PR: https://git.openjdk.org/skara/pull/1364

More information about the skara-dev mailing list