RFR: fix for repeating annotations on type parameter args

Werner Dietl wdietl at gmail.com
Wed Apr 17 14:29:25 PDT 2013


Hi Joel,

thanks for this fix!

Method Attribute.isContainerTypeCompound is not used. Why do we need it?
isContainerTypeCompound checks for values.size() == 1 whereas
getFirstEmbeddedTC checks values.size() >= 1. Should these checks be
consistent?
I would rename hasUnknownLocation and tryFixLocation to
hasUnknownPosition and tryFixPosition as the field is called position.
Some of the changes in Gen.java and RepeatingTypeAnnotations.java use
too much indentation.

More for Steve: in RepeatingTypeAnnotations.java, what does it mean
when "verify" gets "RuntimeVisibleTypeAnnotations:" passed multiple
times? Is the first time used for Code and the second for the Method
attribute? Should this be handled more explicitly?

Joel, as you're now Committer for the type-annotations repository,
please push there.
I agree that, once all tests pass, we should push to TL - even though
the EG is still discussing some details.

Cheers,
cu, WMD.


On Wed, Apr 17, 2013 at 10:26 AM, Joel Borggrén-Franck
<joel.franck at oracle.com> wrote:
> This time with a link to the webrev :)
>
> http://cr.openjdk.java.net/~jfranck/type-annotations/webrev.10/
>
> cheers
> /Joel
>
> On Apr 17, 2013, at 7:25 PM, Joel Borggrén-Franck <joel.franck at oracle.com> wrote:
>
>> Hi Werner, Steve,
>>
>> Here is a small refactoring and fix for the two javac issues with repeating annotations. This also (IMHO) fixes the javap issue so the I've cleaned up the test as my interpretation is that we emit the correct byte code.
>>
>> Werner, I can't push this. If you approve, please commit the fix, should be easy enough from the diff.
>>
>> Perhaps it is time to merge fixes + tests up to tl soon?
>>
>> cheers
>> /Joel
>



-- 
http://www.google.com/profiles/wdietl


More information about the type-annotations-dev mailing list