RFR: fix for repeating annotations on type parameter args
Joel Borggrén-Franck
joel.franck at oracle.com
Thu Apr 18 05:40:20 PDT 2013
Hi Werner, Steve,
On 04/17/2013 11:29 PM, Werner Dietl wrote:
>
> Method Attribute.isContainerTypeCompound is not used. Why do we need it?
I forgot to use it in tryFixPosition(). The logic as written is only
applicable to containers so we should only try fixing containers. It is used
now. There is now a (very) small inefficiency in that I get the first
embedded TC twice but I'm not to worried about that.
> isContainerTypeCompound checks for values.size() == 1 whereas
> getFirstEmbeddedTC checks values.size() >= 1. Should these checks be
> consistent?
Fixed.
> I would rename hasUnknownLocation and tryFixLocation to
> hasUnknownPosition and tryFixPosition as the field is called position.
Fixed.
> Some of the changes in Gen.java and RepeatingTypeAnnotations.java use
> too much indentation.
>
I'm fairly certain it is the other way around, old code using an indent of 3
spaces.
> More for Steve: in RepeatingTypeAnnotations.java, what does it mean
> when "verify" gets "RuntimeVisibleTypeAnnotations:" passed multiple
> times? Is the first time used for Code and the second for the Method
> attribute? Should this be handled more explicitly?
>
That is my interpretaion. First code ("most inner") then method.
> Joel, as you're now Committer for the type-annotations repository,
> please push there.
Ok, will do.
cheers
/Joel
More information about the type-annotations-dev
mailing list