RFR: 8294989: ResourceBundle naming convention issue in JdbcRowSetResourceBundle.java [v12]
Brent Christian
bchristi at openjdk.org
Mon Oct 24 17:57:02 UTC 2022
On Mon, 24 Oct 2022 16:37:56 GMT, Justin Lu <duke at openjdk.org> wrote:
>> Issue: Resource bundle name does not follow proper naming conventions according to [getBundle method](https://docs.oracle.com/en/java/javase/18/docs/api/java.base/java/util/ResourceBundle.html#getBundle(java.lang.String,java.util.Locale,java.lang.Module)) for base name parameter
>>
>> Fix: Modified bundle name to be a fully qualified class and added regression tests.
>
> Justin Lu has updated the pull request incrementally with one additional commit since the last revision:
>
> Use data provider for getBundle test
Changes requested by bchristi (Reviewer).
test/jdk/javax/sql/resourceBundleTests/ValidateGetBundle.java line 81:
> 79: Arguments.of(PATH_TO_BUNDLE, false)
> 80: );
> 81: }
I think the literals can be used in `bundleProvider` - no need to define constants.
Also, `@DataProvider`s are typically located towards the beginning of the file.
-------------
PR: https://git.openjdk.org/jdk/pull/10612
More information about the core-libs-dev
mailing list