RFR: 8325541: C2 SuperWord: refactor filter / split [v2]
Emanuel Peter
epeter at openjdk.org
Fri Feb 9 19:14:16 UTC 2024
On Fri, 9 Feb 2024 15:21:28 GMT, Emanuel Peter <epeter at openjdk.org> wrote:
>> src/hotspot/share/opto/superword.cpp line 1792:
>>
>>> 1790: if (keep) {
>>> 1791: assert(i >= new_packset_length, "only move packs down");
>>> 1792: _packset.at_put(new_packset_length++, pack);
>>
>> Since you use this pattern in multiple places now, how about having a `PackSetRemover` that handles iteration and safe removal without requiring the user to keep track of the length and doing the truncation itself? We could for example execute the truncation with `trunc_to` in the destructor (if we ensure that it is a `StackObj`).
>
> Is it ok if I leave that for a future RFE, where I refactor the `_packset` to a `PackSet` class?
> [JDK-8325252](https://bugs.openjdk.org/browse/JDK-8325252) C2 SuperWord: refactor the packset
I was actually just able to refactor the code of `filter_packs_for_alignment` to use the code in `filter_packs`. Now there is less code duplication!
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/17785#discussion_r1484707647
More information about the hotspot-compiler-dev
mailing list