RFR: 8325541: C2 SuperWord: refactor filter / split [v2]

Christian Hagedorn chagedorn at openjdk.org
Mon Feb 12 08:54:07 UTC 2024


On Fri, 9 Feb 2024 19:10:48 GMT, Emanuel Peter <epeter at openjdk.org> wrote:

>> Is it ok if I leave that for a future RFE, where I refactor the `_packset` to a `PackSet` class?
>> [JDK-8325252](https://bugs.openjdk.org/browse/JDK-8325252) C2 SuperWord: refactor the packset
>
> I was actually just able to refactor the code of `filter_packs_for_alignment` to use the code in `filter_packs`. Now there is less code duplication!

That's nice!

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/17785#discussion_r1485877384


More information about the hotspot-compiler-dev mailing list