RFR: 8311946: add support for libgraal specific jtreg tests [v3]
Vladimir Kozlov
kvn at openjdk.org
Thu Jul 13 18:56:17 UTC 2023
On Thu, 13 Jul 2023 18:23:49 GMT, Doug Simon <dnsimon at openjdk.org> wrote:
>> test/jtreg-ext/requires/VMProps.java line 127:
>>
>>> 125: map.put("vm.graal.enabled", this::isGraalEnabled);
>>> 126: // vm.libgraal is true if the libgraal shared library file is present
>>> 127: map.put("vm.libgraal", this::hasLibraal);
>>
>> May be the property also should be named "vm.hasLibgraal" to be clear what it means.
>
> I'm not so sure. The current naming seems consistent with other existing properties:
>
> map.put("vm.jvmti", this::vmHasJVMTI);
> map.put("vm.jvmci", this::vmJvmci);
>
> However, I can change it if you insist.
I would prefer naming similar to "vm.hasJFR", "vm.hasSA", "vm.hasDTrace". It is unfortunate that we used "vm.jvmci" and "vm.jvmti" naming to check presence of features.
Also libgraal is not part of VM. May be you need to use "jdk.hasLibgraal". There are other properties which use "jdk." already.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/14851#discussion_r1262943734
More information about the hotspot-dev
mailing list