RFR (S): 8034868 Extract G1 From Card Cache into separate class
Jon Masamitsu
jon.masamitsu at oracle.com
Mon Mar 3 20:54:16 UTC 2014
Thomas,
Change looks correct.
Would you consider "contains_or_replace()" as a better name for
"contains_and_update()"?
Did you consider dropping the "_from_card" from the
variable names
53 static int** _from_card_cache;
54 static uint _from_card_cache_max_regions;
55 static size_t _from_card_cache_mem_size;
You dropped the "_from_card_cache" from some names.
"init_from_card_cache" became "initialize" for example.
That's all. Small points so I'm fine with whatever you decide.
Jon
On 3/3/14 3:49 AM, Thomas Schatzl wrote:
> Hi all,
>
> can I get reviews for the following small change? It extracts the from
> card cache previously embedded into the OtherRegionsTable into a
> separate class, named FromCardCache.
>
> This cleans up the remembered set somewhat.
>
> While looking through the code I found that the remembered set code
> still using int's for thread id's. I did not clean that up here, created
> a new CR instead (https://bugs.openjdk.java.net/browse/JDK-8036116)
> since that change would ripple through to quite a few places.
>
> Webrev:
> http://cr.openjdk.java.net/~tschatzl/8034868/webrev/
>
> CR:
> https://bugs.openjdk.java.net/browse/JDK-8034868
>
> Testing:
> JPRT
>
> Thanks,
> Thomas
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.openjdk.org/pipermail/hotspot-gc-dev/attachments/20140303/ccbc2823/attachment.htm>
More information about the hotspot-gc-dev
mailing list