RFR: JDK-8302102: Disable ASan for SafeFetch and os::print_hex_dump [v2]

Justin King jcking at openjdk.org
Fri Feb 10 19:43:11 UTC 2023


On Fri, 10 Feb 2023 05:12:36 GMT, Thomas Stuefe <stuefe at openjdk.org> wrote:

>> Justin King has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   Remove static
>>   
>>   Signed-off-by: Justin King <jcking at google.com>
>
> src/hotspot/os/windows/safefetch_windows.hpp line 35:
> 
>> 33: 
>> 34: template <class T>
>> 35: ATTRIBUTE_NO_SANITIZE_ADDRESS static inline T SafeFetchXX(const T* adr, T errValue) {
> 
> Wait, why is this static now?

Habit. Removed it to be consistent with the rest of the declarations.

> src/hotspot/share/sanitizers/address.hpp line 32:
> 
>> 30: #endif
>> 31: 
>> 32: // ATTRIBUTE_NO_SANITIZE_ADDRESS
> 
> Can we find a better name for this? Its lengthy but still not very clear. E.g. as a prefix to a function it reads like it does something to the - should there be one - return pointer of the function.
> 
> proposal: ASAN_DISABLE

I was mostly going for being consistent with other uses in globalDefinitions. Most things are ATTRIBUTE_X where X is the actual attribute name.

Maybe ATTRIBUTE_NO_ASAN if we want something shorter?

-------------

PR: https://git.openjdk.org/jdk/pull/12477


More information about the hotspot-runtime-dev mailing list