ConcurrentHashMap/ConcurrentMap/Map.compute

Raab, Donald Donald.Raab at gs.com
Fri Dec 7 09:34:51 PST 2012


> -----Original Message-----
> From: lambda-libs-spec-experts-bounces at openjdk.java.net [mailto:lambda-
> libs-spec-experts-bounces at openjdk.java.net] On Behalf Of Doug Lea
> Sent: Friday, December 07, 2012 11:37 AM
> To: lambda-libs-spec-experts at openjdk.java.net
> Subject: Re: ConcurrentHashMap/ConcurrentMap/Map.compute
> 
> On 12/07/12 11:28, Remi Forax wrote:
> 
> > I just don't like compute, the verb is too generic,
> update/updateValue
> > is perhaps better.
> 
> I hated it too when Bob Lee et al lobbied for it, but enough years have
> gone by that I often forget that I hate it :-) Maybe this will happen
> to me some decade for "Block"...
> 
> (The main reason for keeping "compute" is the Guava precedence.)
> 
> -Doug
> 
>

We went with the equivalent names in Smalltalk's Dictionary class (surprise!).  They're not quite as nice without keyword message support, but they are easy enough to understand IMO.

    /**
     * Get and return the value in the Map at the specified key.  Alternatively, if there is no value in the map at the key,
     * return the result of evaluating the specified Function0, and put that value in the map at the specified key.
     */
    V getIfAbsentPut(K key, Function0<? extends V> function);

    /**
     * Get and return the value in the Map at the specified key.  Alternatively, if there is no value in the map for that key
     * return the result of evaluating the specified Function using the specified parameter, and put that value in the
     * map at the specified key.
     */
    <P> V getIfAbsentPutWith(K key, Function<? super P, ? extends V> function, P parameter);

    /**
     * Return the value in the Map that corresponds to the specified key, or if there is no value at the key, return the
     * result of evaluating the specified Function0.
     */
    V getIfAbsent(K key, Function0<? extends V> function);

    /**
     * Return the value in the Map that corresponds to the specified key, or if there is no value at the key, return {@code value}.
     */
    V getIfAbsentValue(K key, V value);

    /**
     * Return the value in the Map that corresponds to the specified key, or if there is no value at the key, return the
     * result of evaluating the specified function and parameter.
     */
    <P> V getIfAbsentWith(K key, Function<? super P, ? extends V> function, P parameter);

    /**
     * If there is a value in the Map that corresponds to the specified key return the result of applying the specified
     * Function on the value, otherwise return null.
     */
    <A> A ifPresentApply(K key, Function<? super V, ? extends A> function);

These are split between MutableMap and MapIterable (MutableMap's readable parent).

https://github.com/goldmansachs/gs-collections/blob/master/collections-api/src/main/java/com/gs/collections/api/map/MutableMap.java
https://github.com/goldmansachs/gs-collections/blob/master/collections-api/src/main/java/com/gs/collections/api/map/MapIterable.java

We have no equivalent of if present do something and put the result back.  Based on our naming scheme it would be something like ifPresentPut or ifPresentApplyPut.

Does computeIfAbsent mutate the map or not?  It is not clear from the name. I like explicit names.  

BTW, putIfAbsent is already a precedent as well.





More information about the lambda-libs-spec-observers mailing list