flatMap

Brian Goetz brian.goetz at oracle.com
Wed Dec 19 11:37:51 PST 2012


> I think we should not use the name 'yield' because it can be a keyword
> added later if we introduce coroutine, generator, etc.

I thought of that.  Then I realized we already have "Thread.yield" among 
others in the libraries, so there's no reason to use a suboptimal name 
just to avoid using the y-word.

Are you saying that yieldInto is actually a *better* name?  Or are you 
just trying to avoid a possible collision?




More information about the lambda-libs-spec-observers mailing list