Cannot build loom jdk after recent changes

Arkadiusz Gasiński jigga at
Mon Dec 16 23:37:29 UTC 2019

Hi Alan,

Just tried that and it worked, thanks!

For the reference what I did was (in the folder with loom sources):

rm -rf build
bash configure --with-boot-jdk=/path/to/jdk-13.0.1.jdk
make images

Thanks again,

On Mon, Dec 16, 2019 at 8:48 AM Alan Bateman <Alan.Bateman at>

> On 15/12/2019 20:38, Arkadiusz Gasiński wrote:
> > Well, my current JAVA_HOME points to the loom JDK that I built like a
> > week ago and I assume that it's my boot JDK
> Can you blow away your build directory and re-run configure with the
> `--with-boot-jdk` option set to a JDK 13? It is possible for a JDK build
> to re-build itself (the so-called "bootcycle build") but building a JDK
> with a mismatch build of itself is never reliable and has never been a
> supported way to do the build (yes, it does work sometimes, not others;
> the errors when it fails are always hard to decipher).
> -Alan

More information about the loom-dev mailing list