heads up: JSR 292 name change
Rémi Forax
forax at univ-mlv.fr
Wed May 11 11:12:29 PDT 2011
On 05/11/2011 03:55 PM, John Rose wrote:
> As previously discussed (late March of this year), the JSR 292 draft spec. uses the word "generic" in a different sense from the Java language. This was a mistake, and we are going to back off from that term. Instead of saying mh.invokeGeneric(x,y) the spelling will be simply mh.invoke(x,y).
In the API, "generic" means two things.
One is "Object" like in MethodType.genericMethodType() and the other
is "generic invocation", boxing/unboxing/varargs.
So the idea is to remove the prefix "generic" from all method name
related to the "generic invocation"
so invokeGeneric=> invoke and genericInvoker => invoker.
For MethodType.genericMethodType(), I think it's better to rename it to
MethodType.objectsMethodType().
I don't like "general", too army oriented :)
> Likewise, lesser-known methods like genericMethodType will (almost certainly) be renamed to something else like generalMethodType. The thing called MHs.genericInvoker will be (by analogy) just MHs.invoker.
>
> This means that if you are fond of calling ".generic()" on your method types to turn all the objects to Object, you'll have to change your code to say ".general()". The old names will be deprecated for a short while.
>
> Best wishes,
> -- John
cheers,
Rémi
More information about the mlvm-dev
mailing list