Do your NSS DLLs on Windows have execute permission?

Bradford Wetmore bradford.wetmore at
Thu Sep 15 18:30:42 UTC 2016


This is a known problem.  We had a discussion on this a couple years 
ago, but I don't know if there's been any additional work on this. 
Perhaps Jon Gibbons might know?  cc'ing him.

As of today's JDK 9 code, look at the "prep" target" in the 
jdk/test/Makefile test directory.  The "prep" target updates the DLLs as 
needed if this is not a repository (which I think is how our build/test 
system JPRT works).

To answer your question, running jtreg directly on that test also fails 
for me, due to:

Caused by: Access is denied.

 > after JDK-8165946[1]
 > [1]

I don't have either of JDK-8165946[text] or JDK-8077138[the bug id in 
the http link above] in my workspace.


On 9/14/2016 1:52 AM, Weijun Wang wrote:
> I see PKCS11 tests fail on my Windows 10 after JDK-8165946 [1]. After
> discussing with John (who worked on the bug) I found my NSS DLLs do not
> have the execute permission bit and his have.
> Mine is -rw-r--r--, and his is -rwxrwx---+.
> I am using cygwin on Windows 10 64-bit, and I use hg inside cygwin to
> clone the repo. My umask is 0022.
> Do you have that x? If yes, what's wrong with my environment? If no, do
> the tests run fine on your machine? For example, I just tried
> sun/security/pkcs11/Cipher/ and it fails.
> Thanks
> Max
> [1]

More information about the security-dev mailing list