Code Review Request, JDK-8214321: Misleading code in SSLCipher

Anthony Scarpino anthony.scarpino at
Tue Nov 27 00:23:47 UTC 2018

On 11/26/18 4:14 PM, Xue-Lei Fan wrote:
> Hi,
> Please review this code cleanup in
> The code should be fine as readCipherGenerators.length and 
> writeCipherGenerators.length are the same value in the implementation. 
> However, it is misleading to use readCipherGenerators when it is 
> intended to use writeCipherGenerators.  It's nice to have a code cleanup 
> for readability.
> Thanks,
> Xuelei

looks fine.. you'll probably want to put noreg-trivial on the bug


More information about the security-dev mailing list