RFR: 8259291: Cleanup unnecessary local variables

Xue-Lei Andrew Fan xuelei at openjdk.java.net
Wed Jan 6 05:23:02 UTC 2021


In the SunJSSE provider implementation, there are a few local variables that is not necessary. For example: 

    byte[] finished = prfKey.getEncoded(); 
    return finished; 

could be simplified as: 

     return prfKey.getEncoded();

Code clean up, no new regression test.

-------------

Commit messages:
 - 8259291: Cleanup unnecessary local variables

Changes: https://git.openjdk.java.net/jdk/pull/1955/files
 Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=1955&range=00
  Issue: https://bugs.openjdk.java.net/browse/JDK-8259291
  Stats: 20 lines in 6 files changed: 0 ins; 8 del; 12 mod
  Patch: https://git.openjdk.java.net/jdk/pull/1955.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/1955/head:pull/1955

PR: https://git.openjdk.java.net/jdk/pull/1955



More information about the security-dev mailing list