RFR: 8259291: Cleanup unnecessary local variables

Sean Mullan mullan at openjdk.java.net
Wed Jan 6 15:52:02 UTC 2021


On Wed, 6 Jan 2021 05:17:35 GMT, Xue-Lei Andrew Fan <xuelei at openjdk.org> wrote:

> In the SunJSSE provider implementation, there are a few local variables that is not necessary. For example: 
> 
>     byte[] finished = prfKey.getEncoded(); 
>     return finished; 
> 
> could be simplified as: 
> 
>      return prfKey.getEncoded();
> 
> Code clean up, no new regression test.

Marked as reviewed by mullan (Reviewer).

-------------

PR: https://git.openjdk.java.net/jdk/pull/1955


More information about the security-dev mailing list