Integrated: 8259291: Cleanup unnecessary local variables
Xue-Lei Andrew Fan
xuelei at openjdk.java.net
Wed Jan 6 17:01:01 UTC 2021
On Wed, 6 Jan 2021 05:17:35 GMT, Xue-Lei Andrew Fan <xuelei at openjdk.org> wrote:
> In the SunJSSE provider implementation, there are a few local variables that is not necessary. For example:
>
> byte[] finished = prfKey.getEncoded();
> return finished;
>
> could be simplified as:
>
> return prfKey.getEncoded();
>
> Code clean up, no new regression test.
This pull request has now been integrated.
Changeset: df721f0c
Author: Xue-Lei Andrew Fan <xuelei at openjdk.org>
URL: https://git.openjdk.java.net/jdk/commit/df721f0c
Stats: 20 lines in 6 files changed: 0 ins; 8 del; 12 mod
8259291: Cleanup unnecessary local variables
Reviewed-by: mullan
-------------
PR: https://git.openjdk.java.net/jdk/pull/1955
More information about the security-dev
mailing list