Integrated: 8259385: Cleanup unused assignment

Xue-Lei Andrew Fan xuelei at openjdk.java.net
Mon Jan 11 00:37:55 UTC 2021


On Thu, 7 Jan 2021 18:30:27 GMT, Xue-Lei Andrew Fan <xuelei at openjdk.org> wrote:

> In the SunJSSE provider implementation, there are a few cases that the assigned value is never used.  For example:
>   int i = 0;
>   i = Byte.toUnsignedInt(buf.get());
> could be simplified as
> `    int i = Byte.toUnsignedInt(buf.get());`
> 
> Code cleanup, no new regression test.

This pull request has now been integrated.

Changeset: b72de3c5
Author:    Xue-Lei Andrew Fan <xuelei at openjdk.org>
URL:       https://git.openjdk.java.net/jdk/commit/b72de3c5
Stats:     95 lines in 18 files changed: 16 ins; 25 del; 54 mod

8259385: Cleanup unused assignment

Reviewed-by: attila

-------------

PR: https://git.openjdk.java.net/jdk/pull/1984



More information about the security-dev mailing list