RFR: 8259385: Cleanup unused assignment [v2]

Xue-Lei Andrew Fan xuelei at openjdk.java.net
Sun Jan 10 21:20:10 UTC 2021


> In the SunJSSE provider implementation, there are a few cases that the assigned value is never used.  For example:
>   int i = 0;
>   i = Byte.toUnsignedInt(buf.get());
> could be simplified as
> `    int i = Byte.toUnsignedInt(buf.get());`
> 
> Code cleanup, no new regression test.

Xue-Lei Andrew Fan has updated the pull request incrementally with one additional commit since the last revision:

  Typo correction, temproary

-------------

Changes:
  - all: https://git.openjdk.java.net/jdk/pull/1984/files
  - new: https://git.openjdk.java.net/jdk/pull/1984/files/9a31381b..3ba6e4d7

Webrevs:
 - full: https://webrevs.openjdk.java.net/?repo=jdk&pr=1984&range=01
 - incr: https://webrevs.openjdk.java.net/?repo=jdk&pr=1984&range=00-01

  Stats: 12 lines in 1 file changed: 0 ins; 0 del; 12 mod
  Patch: https://git.openjdk.java.net/jdk/pull/1984.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/1984/head:pull/1984

PR: https://git.openjdk.java.net/jdk/pull/1984



More information about the security-dev mailing list