RFR: 8243585: AlgorithmChecker::check throws confusing exception when it rejects the signer key
Anthony Scarpino
ascarpino at openjdk.java.net
Tue Oct 19 17:18:55 UTC 2021
On Tue, 19 Oct 2021 15:48:57 GMT, Sean Mullan <mullan at openjdk.org> wrote:
>> src/java.base/share/classes/sun/security/util/AlgorithmDecomposer.java line 196:
>>
>>> 194: static String canonicalName(String algorithm) {
>>> 195: return CANONICAL_NAME.getOrDefault(algorithm, algorithm);
>>> 196: }
>>
>> I'm not sure if `canonicalName` is good. Normally, we say "SHA-1" is the standard name but this method changes it to "SHA1".
>
> Right, it's really just about using consistent message digest names so that it can match for example, "SHA-1" and also "SHA1withRSA". I'll change the name to something else.
Was the reason for this change that hashName("RSASSA-PSS") was returning an RSASSAPSS?
-------------
PR: https://git.openjdk.java.net/jdk/pull/5928
More information about the security-dev
mailing list