RFR: 8243585: AlgorithmChecker::check throws confusing exception when it rejects the signer key

Sean Mullan mullan at openjdk.java.net
Tue Oct 19 17:18:55 UTC 2021

On Tue, 19 Oct 2021 17:15:48 GMT, Anthony Scarpino <ascarpino at openjdk.org> wrote:

>> Right, it's really just about using consistent message digest names so that it can match for example, "SHA-1" and also "SHA1withRSA". I'll change the name to something else.
> Was the reason for this change that hashName("RSASSA-PSS") was returning an RSASSAPSS?



PR: https://git.openjdk.java.net/jdk/pull/5928

More information about the security-dev mailing list