RFR: 8331008: Implement JEP 478: Key Derivation Function API (Preview) [v10]

Valerie Peng valeriep at openjdk.org
Tue Aug 13 21:28:54 UTC 2024


On Tue, 13 Aug 2024 14:31:59 GMT, Kevin Driver <kdriver at openjdk.org> wrote:

>> src/java.base/share/classes/javax/crypto/KDF.java line 52:
>> 
>>> 50:  * of methods. For <a href="https://www.rfc-editor.org/rfc/rfc5869">RFC 5869</a>,
>>> 51:  * KDF algorithm names follow a naming convention of
>>> 52:  * <em>Algorithm</em>With<em>PRF</em>. For instance, a KDF implementation of
>> 
>> I only see HKDF mentioned in RFC 5869. There is no naming convention of <Algorithm>With<PRF> anywhere. Is there any other spec/standard or crypto libraries using this naming?
>
> @valeriepeng: There are `Cipher`s with this convention, namely: `PBEWithHmacSHA512/256AndAES_256` and many others. In addition, there are corresponding `AlgorithmParameters` and `SecretKeyFactory` declarations.

Yes, I am aware of the Cipher transformations, etc. It's just that the sentence seems to imply the naming convention is from RFC 5869.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/20301#discussion_r1715946871



More information about the security-dev mailing list