RFR: JDK-8301070: Replace NULL with nullptr in share/memory/ [v2]

Johan Sjölen jsjolen at openjdk.org
Thu Jan 26 15:08:42 UTC 2023


On Thu, 26 Jan 2023 15:04:06 GMT, Johan Sjölen <jsjolen at openjdk.org> wrote:

>> src/hotspot/share/memory/metaspace/blockTree.hpp line 228:
>> 
>>> 226:       DEBUG_ONLY(check_node(insertion_point);)
>>> 227:       if (n->_word_size == insertion_point->_word_size) {
>>> 228:         add_to_list(n, insertion_point); // parent stays null in this case.
>> 
>> Small nit. Do we have a unified naming scheme for comments?
>>  
>> "null" reads like a java null. I prefer keeping NULL in comments.
>
>>Small nit. Do we have a unified naming scheme for comments?
> 
> Yeah, I forgot to update the PR message with all of the info. If you check now you can see what's been decided upon. The discussions can be found in previous PRs, I can link to them if you're curious.
> 
>>"null" reads like a java null. I prefer keeping NULL in comments.
> 
> That's true, but this probably can be inferred from context which one is meant quite easily? I'd be more keen on explicitly saying that something is a Java null.

FWIW, from fixing these reviews I've never seen us referring to a Java null when we meant a C++ nullptr.

-------------

PR: https://git.openjdk.org/jdk/pull/12185


More information about the serviceability-dev mailing list