RFR: 8330076: [NMT] add/make a mandatory MEMFLAGS argument to family of os::reserve/commit/uncommit memory API [v13]

Afshin Zafari azafari at openjdk.org
Tue Apr 23 08:43:35 UTC 2024


On Tue, 23 Apr 2024 07:16:48 GMT, Thomas Stuefe <stuefe at openjdk.org> wrote:

>> src/hotspot/share/memory/virtualspace.cpp line 45:
>> 
>>> 43: // Dummy constructor
>>> 44: ReservedSpace::ReservedSpace() : _base(nullptr), _size(0), _noaccess_prefix(0),
>>> 45:     _alignment(0), _fd_for_heap(-1), _special(false), _executable(false), _nmt_flag(mtNone) {
>> 
>> Isn't just `_flag` or `_memflag` sufficient as a name for `ReservedSpace`? We don' use `nmt_flag` anywhere else in the codebase.
>
> Yes, I would keep consistency with existing code, and maybe later rename all in one followup change

Done.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/18745#discussion_r1575876690


More information about the shenandoah-dev mailing list