[9] RFR: 7145757: CertificateExtensions uses non-consistent key names
Jason Uh
jason.uh at oracle.com
Fri Mar 27 21:19:16 UTC 2015
On 03/27/2015 03:53 AM, Wang Weijun wrote:
>
>> On Mar 27, 2015, at 06:37, Jason Uh <jason.uh at oracle.com> wrote:
>>
>> Please review this revision:
>> http://cr.openjdk.java.net/~juh/7145757/01/
>>
>> * a global nameCache is maintained in OIDMap as suggested
>
> Can you just use the existing OIDMap.getId() method? It looks like your getCachedOid(name) is the same as getId("x509.info.extensions." + name).
>
> In fact, since the OIDMap only contains mapping of extensions, I'd suggest renaming it to ExtensionMap and change the name inside to short names (without the "x509.info.extensions." prefix).
OK, thanks for that suggestion. I thought there was some significance to
using the "full" name in OIDMap, but if that's not necessary, it makes
things more flexible. Here is the latest revision that uses only the
existing OIDMap (now called ExtensionsMap).
http://cr.openjdk.java.net/~juh/7145757/02/
Thanks,
Jason
> --Max
>
More information about the security-dev
mailing list